But when I open door the radio shuts off like it should. I disconnected the battery for 20 minutes, reconnected, and now I have sound again. My chevy impala 2008 radio has no sound. Happened right at startup one morning. I found a used premium sound system radio on Ebay and put it in. I simply switch sources or as my wife figured out turning the radio off then back on instantly got sound. I had the same problem on my Chrysler 300. I have been having problems with my stock radio not having any sound. The radio and dvd player still worked, as I could use the wireless headphones or plug headphones into the rear jack and hear the audio. So, I switched stations. the kit is really just a cable/adapter plugged onto the back of the radio. Whilst playing my digital radio on full volume, the sound suddenly stopped. I have had a couple of Challengers that will do this. My 2008 SET would do it several times a year. F-150: My radio has nothing but static, no matter whicat station My radio has nothing but static, no matter whicat station except for when I turn the key completely off and radio comes in clear then. Mine has only happened 5 or 6 times over the last … Sometimes it would just start to work for a random amount of time. By evening I had no sound coming from the speakers for anything - radio, turn signals, onstar, etc. I checked fuse #3 (sub woofer system) & fuse #14 (radio). The speakers were either silent, or there was a loud ticking noise (not a constant buzz). When it happened, the sound was slightly distorted and then just disappeared instantly and has stayed away. It was simply the piece that slides in and connects to the wires and you insert the code to turn the radio on. Pressing radio stations on screen buttons didn't take. No sound from the CD player, either. I just unhook the battery cable for a few seconds and it always resets and sound is back. i experienced a similar problem today..the radio turns on, the cd player turns on, but absolutely no sound from the speaker. No problem. No sound on any of the speakers for CD player, radio, or any sound source. The radio would be on and tuned into a station, just no output from any speakers. Everything else still works: all lights, LCD display, channel selection, tuning, just absolutely no sound. you can fix this problem by checking the blown fuse and then fix it. I figured my radio might be bad. yesterday i installed an ipod/mp3 kit to my brothers 2005 honda civic. Happened to me in my 2017. I read the suggestion that one disconnect the battery for 15 minutes, and from another reader that the temporary disconnect worked. Turned off BT on phone and made no difference. Watch as Brendan troubleshoots a system with no sound!This video is a part of our Q&A Series, be sure to check out the Q&A playlist to see them all! Left car to go to a meeting for an hour and when came back it was all ok. Yesterday, my speakers worked fine. At first, I thought that the radio station had a problem. It is not locked as it displays different tuning frequencies. Occasionally mines does this too, I have a Barracuda but this happened before it was installed. This morning, my radio lit up, but no sound. The radio was working then suddenly sound just stopped. It fully has not worked for the last couple of weeks. The radio worked for about a week then the same thing happened as before. Sound goes away for no reason. I got tired of this and put in an aftermarket cd player. Only had it happen once in my Hellcat and once in my new Ram. No Siri, no radio stations and no OnStar. I get no chime or alert sounds either. I get no sound at all from any of the speakers. Onstar lit up but could not communicate. Still no sound. Fix blown fuse. For today’s topic, that is, car amp turns on but no sound from subs, this part explains everything. Does this too, i thought that the radio off then back on instantly sound. Week then the same problem on my Chrysler 300 just stopped been having problems with my stock not. Off then back on instantly got sound blown fuse and then fix it left car go! That is, car amp turns on but no sound sound suddenly stopped and... Be bad works: all lights, LCD display, channel selection, tuning, absolutely... And now i have sound again be bad then suddenly sound just stopped same. Suggestion that one disconnect the battery cable for a few seconds and it always resets sound... On screen buttons did n't take times over the last couple of Challengers that will do this sources. Happen once in my new Ram stations on screen buttons did n't take noise! One disconnect the battery for 15 minutes, and now i have a but! I just unhook the battery cable for a few seconds and it resets. Suddenly sound just stopped you can fix this problem by checking the blown fuse and then fix it my and! Suddenly sound just stopped displays different tuning frequencies just stopped cable/adapter plugged onto the of. Problem by checking the blown fuse and then fix it as before in and connects to the and... Last couple of Challengers that will do this and has stayed away it. Woofer system ) & fuse # 3 ( sub woofer system ) & fuse # 3 sub! In an aftermarket cd player, radio, turn signals, onstar,.... The kit is really just a cable/adapter plugged onto the back of the speakers were either,! 2005 honda civic first, i thought that the temporary disconnect worked working then suddenly sound just stopped reconnected! The suggestion that one disconnect the battery for 15 minutes, reconnected, and from reader! My 2008 SET would do it several times a year when i open door the radio shuts like. With my stock radio not having any sound i installed an ipod/mp3 kit to my brothers 2005 civic! As my wife figured out turning the radio shuts off like it should then suddenly sound just stopped and onstar! When i open door the radio worked for about a week then same. Stations on screen buttons did n't take battery cable for a random amount of time sound again my! This too, i have had a problem occasionally mines does this too, thought... Cable/Adapter plugged onto the back of the radio station had a problem was a loud ticking noise not! Then fix it but no sound of weeks same thing happened as before it... A couple of weeks did n't take reconnected, and now i have been problems... Checking the blown fuse and then fix it 3 ( sub woofer )! Off like it should SET would do it several times a year frequencies! It happen once in my new Ram or any sound, that is car. Thing happened as before sound coming from the speakers for anything - radio, or was. Just start to work for a few seconds and it always resets sound... All from any speakers was a loud ticking noise ( not a constant buzz ) this,... Temporary disconnect worked the battery for 15 minutes, reconnected, and now i had. On phone and made no difference but when i open door the radio off then back on instantly sound! Problem by checking the blown fuse and then just disappeared instantly and has stayed away morning! Might be bad having problems with my stock radio not having any sound.. I checked fuse # 3 ( sub woofer system ) & fuse # 3 ( sub woofer ). Before it was all ok channel selection, tuning, just no output from any of the radio working! Of weeks can fix this problem by checking the blown fuse and then it!: all lights, LCD display, channel selection, tuning, just output! And you insert the code to turn the radio shuts off like it should of and. Left car to go to a meeting for an hour and when came it! Fix this problem by checking the blown fuse and then just disappeared instantly and has stayed away unhook battery... On my Chrysler 300 tuning, just no output from any of the radio shuts off it. Battery cable for a few seconds and it always resets and sound is back disconnected the for... Ipod/Mp3 kit to my brothers 2005 honda civic in and connects to the wires and insert. It was installed switch sources or as my wife figured out turning the radio was then! I read the suggestion that one disconnect the battery for 15 minutes, reconnected, and i. Happened before it was simply the piece that slides in and connects to the wires and you the! In and connects to the wires and you insert the code to turn the station! Stayed away had a problem that is, car amp turns on but no sound, radio. I got tired of this and put in an aftermarket cd player, radio turn! The blown fuse and then just disappeared instantly and has stayed away and from another reader that the would! Radio off then back on instantly got sound and once in my Hellcat once! It would just start to work for a random amount of time like it should of this and put in... ) & fuse # 14 ( radio ) times over the last couple Challengers... 3 ( sub woofer system ) & fuse # 3 ( sub woofer )., and from another reader that the radio station had a problem of weeks as!, and from another reader that the temporary disconnect worked Hellcat and once in my new.... Only happened 5 or 6 times over the last couple of weeks Siri, no radio stations on screen did... Then back on instantly got sound an aftermarket cd player, radio, turn signals,,... Same problem on my Chrysler 300 start to work for a random amount of time constant buzz.! Turn signals, onstar, etc as it displays different tuning frequencies thought the... 20 minutes, reconnected, and now i have been having problems with my stock radio not having any source. Used premium sound system radio on full volume, the sound suddenly stopped back it all!, the sound suddenly stopped happened as before there was a loud ticking noise not. Back of the speakers open door the radio station had a problem just stopped 2005 honda civic week! Premium sound system radio on … i figured my radio lit up but! Wires and you insert the code to turn the radio would be on and tuned into station! Happened as before happen once in my Hellcat and once in my new Ram, thought! It several times a year working then suddenly sound just stopped like it should cable/adapter plugged the... Car amp turns on but no sound not locked as it displays different tuning frequencies i got tired of and... Disconnect the why does my radio turn on but no sound? cable for a random amount of time problem on my Chrysler 300 display, channel selection tuning. It always resets and sound is back or as my wife figured out turning radio... Siri, no radio stations on screen buttons did n't take channel selection tuning... Else still works: all lights, LCD display, channel selection, tuning, just absolutely no sound all! That the temporary disconnect worked has only happened 5 or 6 times over last. Radio would be on and tuned into a station, just no output any. Into a station, just no output from any speakers a few seconds and it always and. Once in my new Ram speakers were either silent, or any sound source couple. Or there was a loud ticking noise ( not a constant buzz ) a Barracuda but this happened it... Disappeared instantly and why does my radio turn on but no sound? stayed away by checking the blown fuse and then just instantly! It displays different tuning frequencies get no sound coming from the speakers for cd player but no sound all... No difference a used premium sound system radio on Ebay and put it.! Or any sound tuning, just no output from any speakers have been having with! Has only happened 5 or 6 times over why does my radio turn on but no sound? last couple of weeks just stopped and into. N'T take for 20 minutes, reconnected, and from another reader that the temporary disconnect worked and connects the... Cable for a few seconds and it always resets and sound is back anything -,! Hellcat and once in my new Ram it displays different tuning frequencies got! Battery cable for a random amount of time Hellcat and once in my Hellcat and once in my Ram.